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Introduction

Welcome to Xpress-MP! This guide provides a framework for evaluating Xpress-MP. Using this
guide you will be able to:

1. Verify that the Xpress-MP installation was successful.
2. Decide which Xpress-MP products to evaluate.

3. Evaluate Xpress-MP.

1 Verify that the Xpress-MP installation was successful

You can test that the Xpress-MP installation was successful by launching Xpress-IVE (Windows
operating system only) or by running console commands (all operating systems).

1. Launch Xpress-IVE: Xpress-IVE is the integrated visual development environment for Win-
dows. To run Xpress-IVE, double click on the Xpress-IVE icon on your desktop or select
Start > Programs > Xpress-MP > Xpress-IVE. You may also start up Xpress-IVE by typing
ive in a DOS window or by double clicking onto an Xpress-Mosel model file (file with
extension .mos ).

2. Run console commands: At the command prompt’, type the following sequence of com-
mands:

optimizer

(Enter)
quit

You will see output that looks like the following:

C:\ > optimizer
Xpress-MP Hyper Integer Barrier Optimizer Release 17.00.00
(c) Copyright Dash Associates 1984-2005

Using Xpress-Optimizer [C: \ XpressMP\ bin \ xprs.dll]

Enter problem name >
[xpress C: \] quit

2 Decide which Xpress-MP products to evaluate

In order to make this decision you must consider the type of problem that you wish to solve,
the tools that you wish to use for model development, the tools that you wish to use for model
deployment, and the platform you intend to use.

'To obtain a command prompt under Windows select Start > Programs > Accessories > Command Prompt
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2.1 Type of problem

Xpress-MP has solver engines for different types of problems:

Type of problem Solving engine

Linear Programming (LP) Xpress-Optimizer
Mixed Integer Programming (MIP)

Quadratic Programming (QP)

Mixed Integer Quadratic Programming (MIQP)

Non-Linear Programming (NLP) Xpress-SLP
Mixed Integer Non-Linear Programming (MINLP)

Stochastic Programming (SP) Xpress-SP
Constraint Programming (CP) Xpress-Kalis

Further information

See Xpress-MP documentation (in the docs subdirectory of your Xpress-MP installation or at
http://www.dashoptimization.com/home/secure/documentation):

e Classification of mathematical programming problems: “Xpress-MP Getting Started”, 1.1.
‘Mathematical Programming’.
e Modeling with Mosel, in particular LP/MIP: “Xpress-Mosel User Guide”.

e Formulation of mathematical programming problems: see the book: “Applications of Op-
timization with Xpress-MP", Part I: ‘Developing Linear and Integer Programming models’.

e Stochastic Programming: “Overview of Stochastic Programming Applications” whitepaper.

e Constraint Programming: “Xpress-Kalis User Guide”.

2.2 Tools for model development and specification

Xpress-MP provides the following tools for model development and specification:

e Xpress-Mosel/Xpress-IVE: Mosel is an advanced modeling and programming language.
Xpress-IVE is the integrated visual environment to develop Mosel models.

e Xpress-BCL: Object-oriented library callable from supported programming languages.

e Xpress-Optimizer libraries: Optimizer functions and procedures provided for low-level
integration with applications developed in supported programming languages.

Also, a model may be specified by a matrix in MPS or LP format.

Further information

See the whitepaper “Modeling with Xpress-MP” (available at
http://www.dashoptimization.com/home/services/publications/support_papers.html).

2.3 Tools for model deployment

Model deployment strongly depends on the tool used to specify the model. Deployment is
achieved through the use of Xpress-MP libraries.
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Model specified in Deployed using

Mosel Mosel libraries (C++/C, Java, VB, .NET)
BCL BCL libraries (C, C++, Java, VB, .NET)
Optimizer libraries Optimizer libraries (C++/C, Java, VB, .NET)

Note that for Stochastic Programming (Xpress-SP) and for Constraint Programming (Xpress-
Kalis), the model must be specified using Xpress-Mosel. Also, for Xpress-SLP deployed with
Java and .NET please contact Dash. For Xpress-BCL deployed with .NET please contact Dash.

Further information

See Xpress-MP documentation (in the docs subdirectory of your Xpress-MP installation or at
http://www.dashoptimization.com/home/secure/documentation):
e Introductory examples (Mosel/BCL/Optimizer): “Xpress-MP Getting Started”.

e Mosel libraries examples: “Xpress-Mosel User Guide”, Part lll: "Working with the Mosel
Libraries'.

e Complete application examples (Mosel): “Embedding optimization algorithms” white-
paper (available at
http://www.dashoptimization.com/home/services/publications/support_papers.html).

e Mosel libraries documentation: “Mosel Library Reference Manual”.
e BCL: "BCL Reference Manual”.

e Optimizer: "Optimizer Reference Manual”.

2.4 Platform

Xpress-IVE is available on Microsoft Windows platforms only. Xpress-Kalis is available on Mi-
crosoft Windows, Linux, and Solaris, all 32-bit only. All other products are available on every
supported platform.

3 Evaluate Xpress-MP

The following four typical evaluator scenarios are defined depending on the choice of products
to evaluate (see question 2):

e Scenario 1: Develop the model in Mosel for any kind of problem and deploy in any pro-
gramming language.

Tool for model development: Mosel
Type of problem: Any
Tool for model deployment Mosel Libraries (C++/C, Java, VB, .NET)

e Scenario 2: Develop the model in BCL for problems requiring Xpress-Optimizer and de-
ploy in any programming language.

Tool for model development: BCL
Type of problem: LP, MIP, QP, MIQP
Tool for model deployment BCL Libraries (C, C++, Java, VB, .NET)
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e Scenario 3: Use your custom application to develop the model and then call the Xpress-
Optimizer libraries. Available for problems that can be solved with Xpress-Optimizer.

Tool for model development: Custom application that calls optimizer libraries.
Type of problem: LP, MIP, QP, MIQP, NLP, MNLP
Tool for model deployment Optimizer libraries (C++/C, Java, VB, .NET)

e Scenario 4: Run a matrix that is readily available in LP or MPS format. Such a model
may be executed through the Xpress-IVE, console commands, or applications that call
Xpress-Optimizer library functions.

Each scenario defines a sequence of specific evaluation steps.

3.1 Evaluation steps for Scenario 1

Tool for model development: Mosel
Type of problem: Any
Tool for model deployment Mosel Libraries (C++/C, Java, VB, .NET)

This scenario uses examples from the “Xpress-MP Getting Started” document that can be found
in directory \XpressMP\examples\getting_started\Mosel

3.1.1 Launch Xpress-IVE

Xpress-IVE is the integrated visual development environment for Windows. To run Xpress-IVE,
double click on the Xpress-IVE icon on your desktop, select Start >> Programs > Xpress-MP >
Xpress-IVE. Otherwise, you may also start up IVE by typing ive in a DOS window or by double
clicking on a model file (file with extension .mos).

3.1.2 Open Mosel model in Xpress-IVE

To open a Mosel model file select File > Open. Locate the directory containing the evaluation
examples (Examples\Getting Started\Mosel ) and open the file foliolp.mos . The model
"Portfolio optimization with LP" will open in the central pane (the IVE editor). This model seeks
an optimal investment portfolio using ten securities (shares), subject to some risk and regional
constraints. The comments in the code (text following the exclamation mark ‘!") describe the
meaning of the different statements. Note that RETis an array of real values representing the
expected return of the shares. The decision variables in the model are given by the array frac

of type mpvar. The procedure maximize calls Xpress-Optimizer to maximize the objective
function. The code also contains statements to print the optimal solution and solution values.

Further information

e For more information on the model formulation for this example see: “Xpress-MP Getting
Started”, Chapter 2: ‘Building models’.

e For more information on the Mosel representation of the model for this example see:
“Xpress-MP Getting Started”, 3.2 ‘LP model".

e For more information on the Xpress-IVE editor see Xpress-IVE Help (Select Help > Xpress-
IVE Help > The Editor).

e For more information on Mosel and other Mosel examples see “Xpress-Mosel User Guide”,
Chapter 1: ‘Getting started with Mosel’, 1.1 ‘Entering a model'.
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3.1.3 Compile and run the Mosel model

To compile the Mosel model select Build > Compile. The status of the compilation is shown at
the bottom of Xpress-IVE (Build view of the Info Bar), and it should read foliolp.mos compiled
successfully. Upon successful compilation, the Project Bar on the left is populated with the
entity tree, which contains all the identifiers in the Mosel model. Successful compilation also
creates the compiled Mosel file foliolp.bim

Further information

e For more on compilation and compilation errors see: “Xpress-MP Getting Started”, 3.3.
‘Correcting errors and debugging a model’.

e For more on Xpress-IVE see the Xpress-IVE Help: Project Bar, Info Bar.

To run the Mosel model select Build > Run. If it was not previously compiled, running the
model will also compile it. Upon successful execution, the right window (Run Bar) displays
output from the Mosel code and from the Xpress-Optimizer on its various tabs. In particular,
the Output/Input tab shows the output printed by the solution printing statements in the
Mosel model, and the Stats and Matrix tabs show output from the Xpress-Optimizer. Also, the
values of the entity tree identifiers are displayed on tooltips or view dialogs (when clicking on
identifier) after the problem is solved.

String indices: The model data and solution are more easily understandable when using string
indices. Open and run model foliolps.mos . Explore output tabs and the entity tree.

Further information

e For more information on running the Mosel model for this example see: “Xpress-MP
Getting Started”, 3.4. 'Solving, optimization displays and viewing the solution’.

e For more information on Xpress-IVE see the Xpress-IVE Help >> Run Bar tabs/panes.

e For more information on string indices for this example see: “Xpress-MP Getting Started”,
3.4.1. 'String indices’, and also “Xpress-Mosel User Guide”, 2.1.3. ‘The burglar problem
revisited'.

3.1.4 Work with data in Mosel

In Mosel models you may work with a large variety of data sources, ranging from simple text
files and other file formats such as databases to data exchanged in memory between a Mosel
model and a host application or between several concurrent Mosel models. We show here the
most frequent cases, namely text files and database access via ODBC.

Text files
Open and run model foliodata.mos . Note that this model has a parameters block and
an initializations from block. The parameters include the data input file, output file,

and other model constants. Parameters can be reset at run time, and they are particularly
important when a model is deployed within a business application. The initializations

from block reads data from the file folio.dat . This file has a Mosel-specific format that can
be seen by opening it in Xpress-IVE: (File > Open >> Files of type: data file (*.dat)). The index
sets and data arrays in the model are created dynamically based on the data in the input file.
Finally this model directs the solution output to an external free-format file result.dat by
calling the procedures fopen and fclose.
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Further information

For more information on working with data and using parameters in Mosel see: “Xpress-MP
Getting Started”, Chapter 4: ‘Working with data’. See also the Xpress-IVE wizard for parame-
ters, data input, and text output.

Accessing databases or spreadsheets through ODBC

Open and run model folioodbc.mos . The initializations from block in this program
reads data from an ODBC data source. The model is accompanied by data in MS Access and
Excel files (folio.mdb  and folio.xls ). You may obtain data from either file by re-setting
the parameter DATAFILE. Note that this example changes the sets RISK and NAinto arrays of
Booleans to receive the data from the database. The initializations to block outputs the
problem results back to the database. When writing to an Excel database, the Excel file must
be closed. Also note that output records are appended to database tables. To begin a fresh
target range in Excel you must delete (not just clear) existing records.

Warning: In order to run this example, the ODBC driver for the corresponding data source
must be present. Also, in Windows you must make sure that a User Data Source called “Excel
Files” is setup in the ODBC Data Source Administrator (Windows 2000 or XP: Start >> Settings
> Control Panel > Administrative Tools > Data Sources (ODBC)). Similarly, for MS Access, the
name of the Data Source is “MS Access Database”.

Further information

e Using ODBC: “Xpress-Mosel User Guide”, Chapter 2: ‘Some illustrative examples’.

e Documentation of the ODBC module: “Mosel Language Reference Manual”, Chapter 8:
‘'mmodbc’.

e Overview of other possibilities of data exchange with external sources: “Xpress-Mosel
User Guide”, 16.1 ‘Generalized file handling’.

e Examples of advanced communication methods with external data sources are given in
the whitepaper “Generalized file handling in Mosel”.

3.1.5 Mosel MIP and quadratic models

Open and run the following Mosel models:

foliomipl.mos : This model introduces the array of binary variables buy to impose a con-
straint limiting the number of different shares taken into the portfolio.

foliomip2.mos  : This model redefines the array of variables frac to be semi-continuous, so
that at least a certain minimum amount of the budget is spent on each share that is bought.

foliogp.mos  : This model uses a quadratic formulation to minimize the portfolio variance
subject to achieving a target expected return. The Mosel program solves the problem twice,
where the second run imposes a limit on the number of shares taken into the portfolio.

For each model, explore the solution and information displayed in the Run Bar tabs.

Further information

e “"Xpress-MP Getting Started”, Chapter 6: ‘Mixed Integer Programming’ and Chapter 7:
‘Quadratic Programming’.

e Complete list of available MIP variable types: “Xpress-Mosel User Guide”, Chapter 4: ‘In-
teger Programming’.
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3.1.6 Other problem types: Constraint Programming, nonlinear and stochastic models

All models we have seen so far use Xpress-Optimizer for problem solving (chosen with the
statement uses "mmxprs" at the begin of the model). If we wish to use a different solver, we
need to indicate the name of the corresponding solver module.

Open the model assign.mos : this model implements and solves an assignment problem with
Xpress-Kalis, that is, using Constraint Programming (CP) techniques. For given sets of workers
and machines the problem is to assign exactly one worker to every machine, maximizing the
total productivity. The productivity of a worker depends on the machine he is assigned to.

You may observe several differences to the models we have seen previously:

— The solver choice statement now is uses "kalis"

— The CP decision variables are of the type cpvar ; their domain (=admissible values) can be set
with the procedure setdomain

— CP models may have linear constraints (as in the ‘Total productivity’ constraint), however our
model also uses other types of constraint relations, so-called ‘global constraints’. The element
constraint formulates a discrete function in one variable, and the all_different relation
states that all variables in the constraint need to take a different value.

— The CP problem is solved with tree search methods. Instead of using the default search
strategies, it is usually preferable to choose a more problem-specific strategy (using procedure
cp_set_branching ).

— The function cp_maximize is used to invoke the optimization.

All else (general structure, declarations, access to data, output printing) remains unchanged
from what we have seen so far.

When running this model with IVE the entity tree display is populated and the model output
appears in the Output/input pane at the right hand side of the workspace. Detailed informa-
tion about the model execution can be found by selecting the tabs CP stats (summary problem
statistics) and CP search (graphical representation of the CP search tree).

Other solver types available for Mosel include Xpress-SLP for solving Nonlinear Programming
problems and Xpress-SP for stochastic optimization problems. Each of these solver modules
comes with problem-type specific functionality (such as variable and constraint types)—please
see the corresponding manuals. In addition certain IVE displays are adapted to the solver(s)
used by a Mosel model.

Further information

e Xpress-Kalis provides access to the functionality of the Constraint Programming solver
Kalis from within the Mosel environment. For more information about Xpress-Kalis see
the documents “Xpress-Kalis User Guide” and "“Xpress-Kalis Reference Manual”.

o Xpress-SP is an extension of the Mosel language for formulating Stochastic Programming
problems. For more information about Xpress-SP see the document “Xpress Stochastic
Programming Guide”.

e Xpress-SLP is a solver for Non-Linear and Mixed Integer Non-Linear Programming based
on the technique of successive linear approximations. For more information about Xpress-
SLP see the document “Xpress-Mosel SLP Reference Manual”.

3.1.7 Deploying Mosel models

Open a Mosel model and select Deploy > Deploy or click the deploy button. This will open
the Deploy dialog box. Select the programming language you wish to run the Mosel model
from, and click the Next> button. This will open a Source Code Dialog containing the code for
deployment.
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Further information

e Xpress-IVE Help (Select Help > Xpress-IVE Help >> Dialogs > Deploy Dialog).

e Introductory example (VB): “Xpress-MP Getting Started”, Chapter 10: ‘Embedding a Mo-
sel model in an application’.

e Further examples (C/Java/VB): “Xpress-Mosel User Guide”, Part Ill: ‘Working with the Mo-
sel Libraries'.

e Documentation of Mosel C libraries: “Xpress-Mosel Library Reference Manual”.
e Documentation of Mosel Java libraries: “Xpress-Mosel Library Reference Manual JavaDoc".

e Documentation of the Mosel .NET interface: “Xpress-Mosel .NET Interface”.

3.1.8 Exporting matrix files

After executing a Mosel model select Build > Export matrix file in order to generate a file with
an LP or MPS representation of the model.

Further information

e Xpress-IVE Help (select Help > Xpress-IVE Help > Dialogs > Export to Matrix Dialog).
e “Xpress-MP Getting Started”, 9.4 ‘Matrix files'.

e Xpress-IVE Help (select Help >> Xpress-IVE Help >> Dialogs >> Optimizer Dialog).

3.1.9 Mosel console commands

As an alternative to running Mosel models within Xpress-IVE you may execute them with the
Mosel standalone version. This mode is often preferrable for testing and experimentation, for
instance, if you wish to invoke a sequence of model runs from a batch file.

At the command prompt, type the following sequence of commands:

mosel

compile foliolp
load foliolp
run

quit

You will see output that looks like the following:

mosel

** Xpress-Mosel **
(c) Copyright Dash Associates 1998-2006
> compile foliolp
Compiling ‘foliolp’...
> |oad foliolp

> run

Total return: 14.0667
treasury: 30%
hardware: 0%
theater: 20%
telecom: 0%
brewery: 6.66667%
highways: 30%

cars: 0%

bank: 0%

software: 13.3333%
electronics: 0%
Returned value: 0
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> quit
Exiting.

The command sequence above may be shortened to a single line:

mosel -c "exec foliolp"

Further information

See "Xpress-Mosel User Guide”, 1.1 ‘Entering a model’. See also “Xpress-Mosel Reference Man-
ual”, 1.1 ‘What is Mosel’ — ‘Running Mosel'.

3.1.10 Other Mosel topics

In addition to the topics addressed in this guide, the document “Xpress-MP Getting Started”
describes how to draw user graphs in Xpress-IVE (Chapter 5: ‘Drawing user graphs’) and how to
program heuristics with Mosel (Chapter 8: 'Heuristics’). Further details on these topics can be
found in the “Xpress-Mosel User Guide”, Part Il ‘Advanced language features’ that describes
Mosel’s programming facilities and includes other examples of heuristics, and under Part IV
‘Extensions and tools’ — 16.3 ‘Graphics with mmive and mmxad’.

Xpress Application Developer (XAD) extends the functionality of Mosel with a set of functions
and procedures for creating standard graphical user interfaces. To learn more about XAD see
the document “Xpress Application Development Reference Manual”.

Additional examples of modeling and programming with Mosel can be found in the directory
\XpressMP\examples\ . Also, the book “Applications of Optimization with Xpress-MP"” (Dash
Optimization, 2002) shows how to formulate and solve a large number of application problems
with Xpress: http://www.dashoptimization.com/applications_book.html

3.2 Evaluation steps for Scenario 2

Develop a model in BCL for problems requiring Xpress-Optimizer and deploy in any program-
ming language.

Tool for model development: BCL

Type of problem: LP, MIP, QP, MIQP

Tool for model deployment BCL Libraries (C, C++, Java, VB, .NET)
See "Getting Started with Xpress-MP", Part II: ‘Getting started with BCL’, which presents exam-
ples in C++ language with detailed explanation. The examples are also implemented in C, Java,

and VB and they «can be found in the corresponding directories
\XpressMP\examples\bc\"\UGExpl

Further information

More examples and the complete documentation of BCL can be found in the “Xpress-BCL
Reference Manual” and the “Xpress-BCL Javadoc”.

3.3 Evaluation steps for Scenario 3

Use your custom application to develop the model and then call the Xpress-Optimizer libraries.
Available for problems that can be solved with Xpress-Optimizer

Tool for model development: Custom application that calls optimizer libraries.
Type of problem: LP, MIP, QP, MIQP, NLP, MNLP
Tool for model deployment Optimizer libraries (C++/C, Java, VB, .NET)

Evaluate Xpress-MP 9 Evaluator guide


http://www.dashoptimization.com/applications_book.html

See "Getting Started with Xpress-MP"”, Part lll: ‘Getting started with the Optimizer’, which
presents examples in C language with detailed explanation.

Further information

e "Xpress-Optimizer Reference Manual”

e For Non-linear programming (NLP,MNLP) see “Xpress-SLP Program Reference Manual”.

3.4 Evaluation steps for Scenario 4

Run a matrix that is readily available in LP or MPS format. Such a model may be executed
through Xpress-IVE, console commands, or applications that call Xpress-Optimizer library func-
tions.

3.4.1 Xpress-IVE

Select File > Open to open file with matrix file (usually files with extensions .mat , .mps, and
p ). Select Build > Optimize Matrix File to execute problem.

Further information

o Xpress-IVE Help (Select Help >> Xpress-IVE Help > Dialogs > Optimizer Dialog).
e “Xpress-MP Getting Started”, 9.4. ‘Matrix files’

3.4.2 Console commands

At the command prompt, type the following sequence of commands to execute the MPS matrix
in file foliolp.mps:

optimizer
foliolp
readprob
maxim
printsol
quit

You will see output that looks like the following:

> optimizer

Xpress-MP Hyper Integer Barrier Optimizer Release 17.00.00
(c) Copyright Dash Associates 1984-2006

Using Xpress-Optimizer [C: \ XpressMP\ bin \ xprs.dll]
Enter problem name >  foliolp

[xpress C: \] readprob

Reading Problem moselP

Problem Statistics

4 ( 0 spare) rows
10 ( 0 spare) structural columns
29 ( 0 spare) non-zero elements
Global Statistics
0 entities 0 sets 0 set members
[xpress C: \] maxim
Presolved problem has: 3 rows 10 cols 19 non-zeros
Its Obj Value S Ninf Nneg Sum Inf Time
0 42.600000 D 2 0 3.166667 0
5 14.066659 D 0 0 .000000 0

Uncrunching matrix
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5 14.066659 D 0 0
Optimal solution found
[xpress C: \] printsol

Problem Statistics
Matrix moselP
Objective *OBJ*

RHS *RHS*

Problem has 4 rows and 10 structural columns
Solution Statistics

Maximization performed

Optimal solution found after 5 iterations

Objective function value is 14.066659

type c/r to continue, anything else to finish >

Rows Section

Number  Row At Value Slack Value
N 1 *OBJ* BS 14.066659 -14.066659
E 2 R1 EQ 1.000000 .000000
G 3 _R2 LL .500000 .000000
L 4 R3 UL .333333 .000000
type c/r to continue, anything else to finish >
Columns Section

Number Column At Value Input Cost
C 5 frac(l) UL .300000 5.000000
C 6 frac(2) LL .000000 17.000000
C 7 frac(3) BS .200000 26.000000
C 8 frac(4) LL .000000 12.000000
C 9 frac(5) BS .066667 8.000000
C 10 frac(6) UL .300000 9.000000
C 11 frac(7) LL .000000 7.000000
C 12 frac(8) LL .000000 6.000000
C 13  frac(9) BS .133333 31.000000
C 14 frac(10) LL .000000 21.000000

[xpress C: \] quit

Further information

.000000 0

Dual Value
.000000
8.000000

-5.000000
23.000000

Reduced Cost
2.000000
-9.000000
.000000
-14.000000
.000000
1.000000
-1.000000
-2.000000
.000000
-10.000000

RHS

.000000

1.000000
.500000
.333333

Xpress-Optimizer Reference Manual”, Chapter 6: ‘Console and Library functions’.

343

Xpress-Optimizer library functions

See “Getting Started with Xpress-MP”, Chapter 14: ‘Matrix input’, which presents an example
in C language with detailed explanation.
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